
About sounds and Animate CC 
 
Adobe Animate offers several ways to use sound.  
Make sounds that play continuously, independent of the Timeline, or use the Timeline to synchronize 
animation to a sound track.  
 
Add sounds to buttons to make them more interactive, and make sounds fade in and out for a more polished 
sound track. 
 
There are two types of sounds in Animate:  
Event sounds and stream sounds. An event sound must download completely before it begins playing, and it 
continues playing until explicitly stopped.  
 
Stream sounds begin playing as soon as enough data for the first few frames has been downloaded; stream 
sounds are synchronized to the Timeline for playing on a website. 
 
If you’re creating Animate content for mobile devices Animate, also lets you include device sounds in your 
published SWF file.  
 
Device sounds are encoded in the device’s natively supported audio format, such as MIDI, MFi, or SMAF. 
 
You can use shared libraries to link a sound to multiple documents.  
You can also use the ActionScript® 2.0 onSoundComplete event or ActionScript® 3.0 soundComplete 

event to trigger an event based on the completion of a sound. 
 
You can load sounds and control sound playback using prewritten behaviors or media components; the latter 
also provide a controller for stop, pause, rewind, and so on.  
 
You can also use ActionScript 2.0 or 3.0 to load sounds dynamically. 
 
For more information, see attachSound (Sound.attachSound method) and loadSound 

(Sound.loadSound method, in ActionScript 2.0 Language Reference or Sound class in ActionScript 3.0 

Language and Components Reference. 
 

Note: ActionScript 2.0 and ActionScript 1.0 are not supported with Animate CC. 
 
 
 

Importing sounds 
You place sound files into Animate by importing them into the library or directly importing them to stage. 
 
The File > Import > Import to Library menu option places the audio only in the library, and not on the timeline. 
 
When you import an audio file using File > Import > Import to Stage menu option or by dragging and dropping 
the audio file directly to the timeline, the audio will be placed on active frame of the active layer.  
 
If you drag and drop multiple audio files, only one audio file will be imported because one frame can contain 
only one audio. 
  

To import audio, use one of the following methods: 
To import an audio file to library, select File > Import > Import to Library and select the audio file that you 
want to import. 
To import an audio file to stage, select File > Import > Import To Stage and select the audio file that you want 
to import.  



 
Drag-and-drop the audio file directly to the stage. 
 
Note: You can also drag a sound from a common library into the library for the current document. 
 
Animate stores sounds in the library along with bitmaps and symbols. You need only one copy of a sound file 
to use that sound multiple ways in your document. 
 
If you want to share sounds among Animate documents, you can include the sounds in shared libraries. 
 
Animate includes a Sounds library containing many useful sounds that can be used for effects.  
To open the Sounds library, choose Window > Common Libraries > Sounds.  
 
To import a sound from the Sounds library to your Animate file, drag the sound from the Sounds library to the 
Library panel of your Animate file.  
 
You can also drag sounds from the Sounds library to other shared libraries. 
 
Sounds can use large amounts of disk space and RAM. However, mp3 sound data is compressed and smaller 
than WAV or AIFF sound data.  
 
Generally, when using WAV or AIFF files, it’s best to use 16-22 kHz mono sounds (stereo uses twice as much 
data as mono), but Animate can import either 8- or 16-bit sounds at sample rates of 11, 22, or 44 kHz. Sounds 
recorded in formats that are not multiples of 11 kHz (such as 8, 32, or 96 kHz) are resampled when imported 
into Animate. Animate can convert sounds to lower sample rates on export. 
 
If you want to add effects to sounds in Animate, it’s best to import 16-bit sounds. If you have limited RAM, keep 
your sound clips short or work with 8-bit sounds instead of 16‑bit sounds. 
 

Note: (Animate CC only) To import or play sounds in Animate, pre-installing QuickTime or iTunes is not 

needed. 
  

_Supported sound file formats 
You can import the following sound file formats into Animate: 
Adobe Sound (.asnd). This is the native sound format of Adobe® Soundbooth™. 

Wave (.wav) 
 

AIFF (.aif and .aifc) 
 

mp3  
 
You can import these additional sound file formats: 
Sound Designer® II (.sd2) 
 
Sun AU (.au, .snd) 
 
FLAC (.flac) 
 
Ogg Vorbis (.ogg and .oga) 
 
 
The ASND format is a non-destructive audio file format, native to Adobe Soundbooth. ASND files can contain 
audio data with effects that can be modified later, Soundbooth multitrack sessions, and snapshots that allow 
you to revert to a previous state of the ASND file. 
 



** VERY IMPORTANT** WebGL and HTML5 Canvas doctypes support only MP3 and WAV formats. 
 

_Add a sound directly from your computer to the Timeline 
You can import audio directly from your computer over to the Timeline by using any of the following methods: 
 
Select File > Import > Import to Stage and select the audio file that you want to import. 
 
Drag and drop the audio file to the stage/timeline. 
  

Note: that only add one audio file at a time. Dragging and dropping multiple audio files will import only one 

audio file to the timeline. 
 

_Add a sound from the library to the Timeline 
You can add a sound to a document using the library, or you can load a sound into a SWF file during runtime, 
using the loadSound method of the Sound object.  

 
For more information, see Sound Class in the ActionScript 3.0 Reference. 

 

Import the sound into the library if it has not already been imported.     

Select Insert > Timeline > Layer.     
 
With the new sound layer selected, drag the sound from the Library panel onto the Stage. The sound is added 

to the current layer.  You can place multiple sounds on one layer or on layers containing other objects. 

However, it is recommended that each sound be placed on a separate layer.  
 
Each layer acts as a separate sound channel. The sounds on all layers are combined when you play the SWF 
file in the Timeline. 
 

Select the first frame that contains the sound file.     

Select Window > Properties, and click the arrow in the lower-right corner to expand the Property inspector.     

In the Property inspector, select the sound file from the Sound pop-up menu.     
 

Select an effect option from the Effects pop-up menu:   
 

None.    Applies no effects to the sound file. Select this option to remove previously applied effects. 

 

Left Channel / Right Channel.    Plays sound in the left or right channel only.   
 

Fade Left to Right / Fade Right to Left.   Shifts the sound from one channel to the other. 

   

Fade In.   Gradually increases the volume of a sound over its duration.   
 

Fade Out.   Gradually decreases the volume of a sound over its duration.    
 

Custom.   Let you create custom in and out points of sound using the Edit Envelope.  

 

  Note: Effects are not supported on WebGL and HTML5 Canvas documents. 

      

 
Select a synchronization option from the Sync pop-up menu 
 

 Event  . Synchronizes the sound to the occurrence of an event. An event sound plays when its starting 

keyframe first appears and the plays in its entirety, independently of the playhead in the Timeline, even if the 
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SWF file stops playing.  Event sounds are mixed when you play your published SWF file.  
 
If an event sound is playing and the sound is instantiated again (for example, by the user clicking a button 
again, or the playhead passing the starting keyframe of the sound), the first instance of the sound continues to 
play and another instance of the same sound begins to play simultaneously.  
 
**IMPORTANT** Keep this in mind when using longer sounds, as they can potentially overlap, causing 

unintended audio effects.   
 

Start  . The same as Event, except that if the sound is already playing, no new instance of the sound 

plays.   
 

Stop.  Silences the specified sound.    
 

Stream.   Synchronizes the sound for playing on a website. Animate forces animation to keep pace with 

stream sounds. If Animate can’t draw animation frames quickly enough, it skips frames. Unlike event sounds, 
stream sounds stop if the SWF file stops playing.  
 
Also, a stream sound can never play longer than the length of the frames it occupies. Stream sounds are 
mixed when you publish your SWF file.  
 
An example of a stream sound is the voice of a character in an animation that plays in multiple frames.  
 

Note: If you use an mp3 sound as a stream sound, you must recompress the sound for export.  
 
You can export the sound as an mp3 file, with the same compression settings that it had on import. 
 
Animate remembers the audio sync options in property inspector.  
If a sound is selected from the “Sound” section of the Properties Inspector, then on trying to set another sound 
on a new keyframe from the Properties Inspector, Animate, remembers the sync options “Stream” or “Event” of 
the previous sound.  
 

  **VERY IMPORTANT** Stream setting is not supported in WebGL and HTML5 Canvas documents. 

      
Enter a value for Repeat to specify the number of times the sound should loop, or select Loop to repeat the 

sound continuously.   

 
For continuous play, enter a number large enough to play the sound for an extended duration.  
 
For example, to loop a 15-second sound for 15 minutes, enter 60. Looping stream sounds is not 
recommended.  
 
If a stream sound is set to loop, frames are added to the file and the file size is increased by the number of 

times the sound is looped.       
 
To test the sound, drag the playhead over the frames containing the sound or use commands in the Controller 

or the Control menu.     
 
 

_Video: Audio sync settings in Animate 
 

Remove a sound from the Timeline 
In the Timeline layer containing the sound, select a frame that also contains the sound.     

In the Property inspector, go to the Sound section and select None from the Name menu.   



Animate deletes the sound from the Timeline layer.      
 

Add a sound to a button 
You can associate sounds with the different states of a button symbol.  
Because the sounds are stored with the symbol, they work for all instances of the symbol. 
 

Select the button in the Library panel.     

Select Edit from the Panel menu in the upper-right corner of the panel.     
 

In the button’s Timeline, add a layer for sound (Insert > Timeline > Layer).     
 
In the sound layer, create a regular or blank keyframe to correspond with the button state to which you want to 

add a sound (Insert > Timeline > Keyframe or Insert > Timeline > Blank Keyframe).   
For example, to add a sound that plays when you click the button, create a keyframe in the frame labeled 

Down.      
 

Click the keyframe you created.     Select Window > Properties.     

 
In the Property inspector, select a sound file from the Sound pop-up menu. 

     

Select Event from the Sync pop-up menu.   
To associate a different sound with each of the button’s keyframes, create a blank keyframe and add another 
sound file for each keyframe.  
 

You can also use the same sound file and apply a different sound effect for each button keyframe.       
 

Synchronize a sound with animation 
To synchronize a sound with animation, you start and stop the sound at keyframes. 
 
Add a sound to the Timeline in its own layer (see above for instructions). 

     
To synchronize this sound with an event in the scene, create a beginning keyframe for the sound that 
corresponds to the keyframe of the event in the scene that you want to trigger the sound.  
 
You can select any of the synchronization options described above (see Add a sound to the Timeline). 

     

Create a keyframe in the sound layer’s Timeline at the frame where you want the sound to end.  

A representation of the sound file appears in the Timeline.     
 
Select Window > Properties, and click the arrow in the lower-right corner to expand the Property inspector. 

     

In the Property inspector, select the same sound from the Sound pop-up menu.     

 

Still in the Property inspector, select Stop from the Sync pop-up menu.  When you play the SWF file, the 

sound stops playing when it reaches the ending keyframe. 

      

To play back the sound, drag the playhead in the Timeline.     
 

_Edit a sound in Animate  
In Animate, you can define the starting point of a sound or control the volume of the sound as it plays.  
You can also change the point at which a sound starts and stops playing.  
 
**IMPORTANT** This is useful for making sound files smaller by removing unused sections. 
 



Add a sound to a frame, or select a frame that already contains a sound.     
 

Select Window > Properties.     
 

Click the Edit button on the right side of the Property inspector.     
 

Do any of the following:  
To change the start and end points of a sound, drag the Time In and Time Out controls in the Edit Envelope. 
  
To change the sound envelope, drag the envelope handles to change levels at different points in the sound. 
 
Envelope lines show the volume of the sound as it plays.  

       
      To create additional envelope handles (up to eight total), click the envelope lines.  
 
      To remove an envelope handle, drag it out of the window. 
       

To display more or less of the sound in the window, click the Zoom In or Out buttons. 
  

      To switch the time units between seconds and frames, click the Seconds and Frames buttons. 

     

      To hear the edited sound, click the Play button.     
 

Split a sound on timeline 
You can split the stream audio embedded on the timeline using the Split Audio context menu.  
 
Split Audio enables you to pause the audio when it is necessary and then resume the audio playback from the 
point it was stopped at a later frame on the timeline. 
 
To split an audio clip on your timeline: 
 
Select File > Import > Import to library. 
  
Select the audio clip and import it to library. 
  
Create a new layer on your timeline and add the clip to the layer. 
  
Under Properties > Sound, select the Sync type as Streaming. 
 
Right-click on the frame at which you want to split the audio and click Split Audio.  



 
Loop sound on timeline 
for Cascading Toc 
Audio looping means repeating a small section of sound continuously over a number of frames on your 
timeline. With the “loop” option turned on in the timeline, you can loop streaming audio within a range of frames 
along with other animations. 
To create a loop, just turn on the loop option on your timeline as follows: 



 
The Audio Looping button on the timeline 
 
Edit a sound in Soundbooth 
for Cascading Toc 
If you have Adobe Soundbooth installed, you can use Soundbooth to edit sounds you have imported into your 
Animate file. After making changes in Soundbooth, when you save the file and overwrite the original, the 
changes are automatically reflected in the Animate file. 
If you change the filename or format of the sound after editing it, you will need to re-import it into Animate. 
Note: Soundbooth is available only on Windows computers and Intel®-based Macintoshes. 
 
To edit an imported sound in Soundbooth: 

1 Right-click (Windows) or Ctrl-click (Macintosh) the sound in the Library panel.     

2 Choose Edit in Soundbooth from the context menu. The file opens in Soundbooth.     

3 Edit the file in Soundbooth.     
4 When you are finished, save the file. To save the changes in a non-destructive format, choose the ASND 

format.  If you save the file in a different format from the original, you will need to re-import the sound 

file into Animate.      

5 Return to Animate to see the edited version of the sound file in the Library panel.      
6  
Note: You cannot edit sounds from the Sounds library (Window > Common Libraries > Sounds) with the Edit in 
Soundbooth command. To edit these sounds in Soundbooth, open Soundbooth and select the sound from the 
Resource Central panel. Edit the sound and then import it into Animate. 
 
Using sounds in Flash Lite 
for Cascading Toc 
Adobe® Flash® Lite supports two types of sound: standard Animate sounds, like those used in Animate 
desktop applications, and device sounds. Flash Lite 1.0 supports device sounds only; Flash Lite 1.1 and 2.x 
support both standard sounds and device sounds. 
Device sounds are stored in the published SWF file in their native audio format (such as MIDI or MFi); during 
playback, Flash Lite passes the sound data to the device, which decodes and plays the sound. Because you 
can’t import most device audio formats into Animate, you instead import a proxy sound in a supported format 
(such as mp3 or AIFF) that is replaced with an external device sound that you specify. 
You can use device sounds only as event sounds—you can’t synchronize device sounds with the Timeline as 
you can with standard sounds. 
Flash Lite 1.0 and Flash Lite 1.1 do not support the following features available in the desktop version of 
Flash® Player: 
• The ActionScript Sound object 
• Loading of external mp3 files 
• The Speech Audio Compression option 
Fo 


